Solution to Mate buttons not working

Discussion about the OutBack Mate Remote

Moderators: OutBack, OutBack Moderator Team

Solution to Mate buttons not working

Postby drstrip on Mon Nov 13, 2017 8:51 am

For years the buttons on my Mate have been "fussy", to be generous about it. I'd tried all the usual solutions - contact cleaner, light abrasion on the circuit board, light abrasion on the membrane contacts. These had minimal effect at best. Finally I bought some conductive silver paint and dabbed it on the supposedly conductive rubber contacts on the membrane. After letting the paint dry overnight, I put the Mate back together and it works like new.
Forum Virtuoso
Posts: 86
Joined: Mon Jan 08, 2007 1:32 pm
Location: New Mexico - The land of enchantment and 76% of possible sunshine
My RE system: 18 x 160W BP3160 modules
2 x VFX3524
2 x MX 60
HUP SolarOne batteries SO-6-85-33/23 - 1690AH@24V
Kohler 15RYG backup

Re: Solution to Mate buttons not working

Postby rodeworthy on Mon Dec 11, 2017 5:59 pm

Thanks for the post. I too have a fussy Mate. I cannot shut down the network from the Mate. Problem has been ongoing. Last year I removed it and took a look inside to see if I could find a problem. Nothing obvious. I cleaned it up and put it back together. It worked again. Not unusual for low voltage circuitry.

Now the problem is repeating itself. I will give your method a try. Thanks again.

Forum Junior Member
Posts: 1
Joined: Sun Mar 14, 2010 9:39 am
My RE system: RV with 4 135W PV in series to Outback Flexmax 60. 4 x 6V battery array. !2V 464AH.

Return to Mate

Who is online

Users browsing this forum: No registered users and 1 guest