Page 1 of 1

Wildly Wrong Temp Readout on Dashboard of Optics

PostPosted: Wed Dec 05, 2018 1:19 pm
by outrigger999
Hello, has anyone seen the temperature reading that intermittently shows up on the dashboard under the battery? Mine started showing up, I think, after the last OpticsRE update. I've just today updated the Mate3s firmware to see if that would do anything in regards to this and it didn't. Prior to updating to the latest firmware I was running the previous one so I was never far behind. I don't have a temperature sensor attached and 255C is way too high for any of the components to be functional! Nothing is hot to the touch, and I have SimpliPHI PHI 3.4 batteries which each have a BMS, which is to say that they would shut down if there was a thermal problem. I haven't changed any settings on my system for months however if there's a setting that I have which is causing this please let me know so I can turn it off.

Image

Here's the specs of my system:

-Mate 3s
-4 FM80 Charge Controllers
-4 VFX3648 Inverters
-8 SimpliPhi PHI 3.4 batteries
-15.9kW of solar panels

Re: Wildly Wrong Temp Readout on Dashboard of Optics

PostPosted: Wed Dec 05, 2018 1:20 pm
by outrigger999
I should also mention that the temperature never changes and the system has been running normally and well for months now.

Re: Wildly Wrong Temp Readout on Dashboard of Optics

PostPosted: Wed Dec 05, 2018 1:40 pm
by Mike Curran
This feature was added in a November 29 update to Optics. Obviously without a temperature sensor you're gonna get a false reading. Here's the thread describing the details of that update: viewtopic.php?f=46&t=13598

Re: Wildly Wrong Temp Readout on Dashboard of Optics

PostPosted: Wed Dec 05, 2018 1:49 pm
by David LeBow
It is a false reading. We're investigating. We shouldn't be receiving a "255" from the controller or the inverter. If you see 255 (Celsius) or 491 (Fahrenheit)... it's bogus.

We're trying to isolate the source and craft the best solution.

Apologies for the inconvenience and the confusion.

Re: Wildly Wrong Temp Readout on Dashboard of Optics

PostPosted: Wed Dec 05, 2018 1:57 pm
by outrigger999
Thanks everyone for the quick response!

Re: Wildly Wrong Temp Readout on Dashboard of Optics

PostPosted: Sun Jan 13, 2019 5:07 pm
by koalamotorsport
Mine is not wildly out, but by no means accurate either.

My batteries are sitting on 2" of closed cell foam insulation on a 6" concrete floor in a building with 6" walls and R19 wall, R30 ceiling insulation.

That building has been at 58F, or above, all day and my batteries (temp sensor sandwiched between two of them) are showing 44F. And they have been charging all day with almost 38kW of solar power generated, plus another 12kW or so being A/C coupled. So, battery temp should be at least at ambient temp.

This is not a new thing. It's been this far off, or more, since the update when the feature was added.

FYI.