AXS Port Clock bugs

Post Reply
User avatar
intellact
Forum Czar
Posts: 703
Joined: Mon Nov 28, 2005 3:20 am
Location: Ontario, Canada
Contact:

AXS Port Clock bugs

Post by intellact » Thu Aug 17, 2017 5:55 pm

In an earlier post, I made a curious observation:
I wrote:It seems that if you have your AXS Port Time Zone register set to -5 (for example) and the Time Server is Disabled, then every time you reboot your AXS Port, 5 hours gets subtracted from your clock time. :shock: REALLY?!?
So I have more information to add..

Trying to avoid the above issue, I set my Time Zone to 0 (GMT), and still left the Time Server Disabled. That seemed to work for a while.

After a bit, without rebooting my AXS Port, I reconnected to my AXS Port, and guess what? The clock had added 4 hours! ](*,)

Power down, power back up, and another 4 hours have been added! It seems that no Time Zone setting is immune to this bizarre behavior...

MY SOLUTION

What I have done for now is set the Time Server to Enabled and chosen a Time Zone setting that reflects Daylight Saving Time in my time zone. Since I live in Ontario, Canada, I am using GMT-4. I really live in a GMT-5 time zone, but DST is active for more days in the year than non-DST. I'll let my software make the adjustment. :smile:

:?: Has anyone else encountered AXS Port clock strangeness? :?:

(My AXS Port firmware is 003.015.001.)
Andrew Welch, creator of WattPlot

Post Reply