AXS resets randomly

Post Reply
rdk45
Forum Member
Posts: 9
Joined: Tue Mar 19, 2019 6:20 am

AXS resets randomly

Post by rdk45 » Wed Apr 22, 2020 9:06 am

We are having a problem with our Outback AXS Port resetting it parameters, apparently randomly. The unit still seems to function, that is we can get to the data using the SunSpec/Modbus techniques. However, it changes many parameters, like e-mail address, times zone, time servers, etc. This unit has been in continuous service for over 5 year with no issues until now.

We can manually reset the values, but have no idea what is triggering these changes. Can anyone offer some ideas/help?

raysun
Forum Emperor
Posts: 2058
Joined: Tue Jul 26, 2016 5:57 am
My RE system: Flexpower One: FX3048T, (2) FM80, MATE3s, FlexNetDC
Outback 200NC batteries (8 @ 48v)
Outback IBR3 battery enclosure
Suniva 330 watt panels (12 - 6 strings of 2 in series)
Hyundai 355 watt panels (6 - 3 strings of 2 in series)
Honda EU7000is gas fuel generator

Re: AXS resets randomly

Post by raysun » Wed Apr 22, 2020 10:52 am

I'd be suspicious of the devices and communication external to the AXS port, to start.

It would be hard to imagine the AXS internal firmware spontaneously changing those parameters. Not impossible, but lower likelihood than external commands.

Is the system on OpticsRE as well as connected to local monitoring devices?

rdk45
Forum Member
Posts: 9
Joined: Tue Mar 19, 2019 6:20 am

Re: AXS resets randomly

Post by rdk45 » Wed Apr 22, 2020 11:03 pm

Thanks for the reply. We do not have an OpticsRE. When we first got the AXS unit, more that 5 years ago, my son (an IT person) wrote a JAVA program to access the unit to set/change the parms. It has worked without issue for several years.

We first noticed this reset issue when my Python program, which accesses the AXS port to read the system data, would sometimes fail to connect to the AXS port after a complete system power cycle, ether manually initiated or a system shutdown triggered when the panels were snow covered and the system/battery voltage dropped to the lower limit. Power cycling just the AXS unit would fix the program's access. We have since discovered the parameter reset issues.

Thanks again.

Post Reply