MATE3s 1.4.0 firmware causing calibration issue

Mate3 and Mate3s communications devices for Outback Power

MATE3s 1.4.0 firmware causing calibration issue

Postby Megunticook on Mon Jan 28, 2019 7:13 am

A few days ago I upgraded my MATE3s firmware to the latest version, 1.4.0. Twice now I've had to manually fix the Grid Input Voltage Calibrate setting and the AC Output Calibrate setting for the Radian inverter. I would never have even been ware of this except when I tried to change my grid-sell voltage parameter (via Optics) it wouldn't let me, displaying a warning about those two calibration settings. When I check them they were wildly off: Grid Input was 10 and AC Output was -8. When I set them back to 0 everything was fine.

This has happened twice now. Anybody else having this issue?
https://sunnypower.org
User avatar
Megunticook
Forum Guru
 
Posts: 162
Joined: Fri Sep 29, 2017 4:08 am
Location: Maine
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Jeff Bosch on Mon Jan 28, 2019 10:18 am

This issue became apparent after the release. We are testing a fix today. I apologize that this issue was not caught in release testing. I will post an update when we have a planned release date.
Jeff Bosch
Senior Software Engineer
OutBack Power Technologies
User avatar
Jeff Bosch
OutBack Engineering
 
Posts: 20
Joined: Tue Sep 18, 2018 12:06 pm
Location: Arlington, WA USA

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Megunticook on Mon Jan 28, 2019 11:44 am

Thanks, just let me know when you have some updated firmware.
https://sunnypower.org
User avatar
Megunticook
Forum Guru
 
Posts: 162
Joined: Fri Sep 29, 2017 4:08 am
Location: Maine
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Jeff Bosch on Mon Jan 28, 2019 11:47 am

I'll post an update here, plus notification will go out over the normal update channels.
Jeff Bosch
Senior Software Engineer
OutBack Power Technologies
User avatar
Jeff Bosch
OutBack Engineering
 
Posts: 20
Joined: Tue Sep 18, 2018 12:06 pm
Location: Arlington, WA USA

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Megunticook on Tue Jan 29, 2019 2:26 pm

calibration-error.gif
calibration-error.gif (8.54 KiB) Viewed 1584 times
Happened again today--not sure what's triggering it.

Here's a screenshot:
https://sunnypower.org
User avatar
Megunticook
Forum Guru
 
Posts: 162
Joined: Fri Sep 29, 2017 4:08 am
Location: Maine
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Jeff Bosch on Tue Jan 29, 2019 2:43 pm

Unfortunately, it will continue to happen sporadically until we get the new firmware out in the field.
Jeff Bosch
Senior Software Engineer
OutBack Power Technologies
User avatar
Jeff Bosch
OutBack Engineering
 
Posts: 20
Joined: Tue Sep 18, 2018 12:06 pm
Location: Arlington, WA USA

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Megunticook on Tue Jan 29, 2019 3:57 pm

Any timeframe?

Wondering if I should roll back the update.

Don't want to bother with all that but then again I don't want to damage my battery bank. Guess I"ll just keep a very close eye on it...
https://sunnypower.org
User avatar
Megunticook
Forum Guru
 
Posts: 162
Joined: Fri Sep 29, 2017 4:08 am
Location: Maine
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Jeff Bosch on Tue Jan 29, 2019 4:26 pm

If testing continues to go as well as it is today, then sometime next week we'll post the update on the firmware updates page and I'll post a sticky note to the forum.
Jeff Bosch
Senior Software Engineer
OutBack Power Technologies
User avatar
Jeff Bosch
OutBack Engineering
 
Posts: 20
Joined: Tue Sep 18, 2018 12:06 pm
Location: Arlington, WA USA

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Megunticook on Wed Jan 30, 2019 5:15 am

OK, thanks. I checked and fixed it early this morning, then just checked again now and it's reverted back.

Where is it getting those values anyway?
https://sunnypower.org
User avatar
Megunticook
Forum Guru
 
Posts: 162
Joined: Fri Sep 29, 2017 4:08 am
Location: Maine
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Jeff Bosch on Wed Jan 30, 2019 4:15 pm

There's a communication mismatch between the Mate3s and Optics involving scale factors that take a setting and multiply it to get the actual value. The fix is on the way.
Jeff Bosch
Senior Software Engineer
OutBack Power Technologies
User avatar
Jeff Bosch
OutBack Engineering
 
Posts: 20
Joined: Tue Sep 18, 2018 12:06 pm
Location: Arlington, WA USA

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Megunticook on Thu Jan 31, 2019 9:13 am

So the inverter isn't actually using those wild calibration numbers--they're just getting reported wrong on Optics?

I was wondering about that because I've only see in in Optics, when I check the MATE3s directly everything seems normal.

So I guess I don't need to worry about causing any damage to my batteries or system--right? Or should I revert back to the previous firmware just to be safe?
https://sunnypower.org
User avatar
Megunticook
Forum Guru
 
Posts: 162
Joined: Fri Sep 29, 2017 4:08 am
Location: Maine
My RE system: 6.4 kW solar array (21 QCell 305 panels in strings of 3)
GS8048A FLEXpower Radian (Radian 8048A, 2 FlexMax 80 cc's, Mate 3s, FlexNet DC, Hub)
8x6v Rolls-Surette 550 FLA batteries, 428AH

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Jeff Bosch on Thu Jan 31, 2019 11:47 am

The Optics calibration numbers are false and do not reflect the actual settings. The only effect is that you can't change calibration settings in Optics. No need to roll back.
Jeff Bosch
Senior Software Engineer
OutBack Power Technologies
User avatar
Jeff Bosch
OutBack Engineering
 
Posts: 20
Joined: Tue Sep 18, 2018 12:06 pm
Location: Arlington, WA USA

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Zip92 on Mon Feb 11, 2019 5:30 am

Has firmware 1.4.0 been pulled off the website? It doesn't appear on the firmware downloads page...
I see a release date for Feb 7 2019... but no file link.

Is a fix still coming for it? Or has it been dealt with the recent OpticsRE updates?

http://outbackpower.com/resources-mobil ... re-archive
User avatar
Zip92
Forum Whiz
 
Posts: 28
Joined: Wed Jan 04, 2017 5:14 pm
Location: Ontario Canada
My RE system: Canadian Remote Cabin - Solar + Diesel Gen
COMM: Mate3s
INV: x2 VFX3524
CC1: MX-60
CC2: Conext MPPT 80
SOLAR1: 6x 123w (Sharp ND-L3EJEA)
SOLAR2: 12x 250w
BATT: RollsSurrette 24v (2v x 12) S2-1275AGM
GEN: Cummins 10kw Deisel w/ Atkinson GSCM Mini D

Re: MATE3s 1.4.0 firmware causing calibration issue

Postby Jeff Bosch on Mon Feb 11, 2019 9:35 am

Mate3s 1.4.0 was pulled from the website due to the calibration issues. 1.4.1 has fixes for that and is in the process of being released. Sorry that the Web team didn't post a notice that it was being pulled. (I wasn't even notified. It just disappeared one day and I had to ask around to find out what happened.)
Jeff Bosch
Senior Software Engineer
OutBack Power Technologies
User avatar
Jeff Bosch
OutBack Engineering
 
Posts: 20
Joined: Tue Sep 18, 2018 12:06 pm
Location: Arlington, WA USA


Return to Mate3 / Mate3s

Who is online

Users browsing this forum: Google [Bot] and 3 guests