Page 1 of 1

FLEXmax 80 display

Posted: Thu Dec 13, 2018 10:29 am
by HondaLee
After moving to my current location I installed my system and when I turned on dc breakers FLEXmax 80 display has back light and a full screen of black boxes and no letters. The rest of system seems ok so far , can you help

Re: FLEXmax 80 display

Posted: Thu Dec 13, 2018 12:09 pm
by Jorge Guzman
Try doing a "hard reset" on the FM80 controller.

Turn off PV input breaker
Turn off Batt output breaker
While unit is completely off, press and hold buttons #1 and #3 (from left to right)
While still holding the buttons, turn on the battery breaker.

This should reset the unit including settings.

Re: FLEXmax 80 display

Posted: Thu Dec 13, 2018 5:37 pm
by HondaLee
I will try that and get back to you.
I have another question: I have a second FLEXmax 80 that I used to change out the one that is giving problems. With replacement charge controller installed and system up and running I am getting 227vac. I plugged in my cripplecreek car charger and it immediately shows power fault. This is the only load I have running through inverters at this time because my first goal is to use solar to charge my Chevy volt. Thanks

Re: FLEXmax 80 display

Posted: Fri Dec 14, 2018 8:15 am
by Kurt Lundquist
What shows the power fault (Inverter or the car charger)?

Which Clipper Creek Charger are you using?

Have you tried running a different AC load off the inverter output?

-Kurt

Re: FLEXmax 80 display

Posted: Sat Dec 15, 2018 8:54 am
by HondaLee
Clipper creek model LCS-20P
Configuration LCP-20-C11-P1-L25-55
No I havenÔÇÖt tried any other loads yet as I am just getting the system installed but I did check voltage and was getting a little better than 220 vac

Re: FLEXmax 80 display

Posted: Sat Dec 15, 2018 10:53 am
by HondaLee
Did hard reset on charge controller and it made no difference. Every single caricature has Black box in place of letter over hole screen.
What next?

Re: FLEXmax 80 display

Posted: Mon Dec 17, 2018 1:01 pm
by Kurt Lundquist
HondaLee wrote:I plugged in my cripplecreek car charger and it immediately shows power fault.
Kurt Lundquist wrote:What shows the power fault (Inverter or the car charger)?
For the FM80 with the display issues what is your DC negative to ground voltage when the PV array is connected?

Disconnect the PV array then try turning the controller on again. If you still have black boxes connect the Mate3 to the FM80 to see if it can communicate with the FM. If the Mate3 communicates with the FM you can try connecting the PV array again then look at the Mate3 to see if it is doing anything when it is sunny out.

In another thread, you noted 4 x 60 cell PV modules in series (~37V x 4). This is too much voltage for the controller anytime the PV array is below 80F. I recommend only using 3 of these modules in series. Inside the FM80 wiring compartment you can see two red discs near the Mate/Hub port on the left side. If either of these looks compromised it would be due to high voltage from the array.

-Kurt

Re: FLEXmax 80 display

Posted: Tue Dec 18, 2018 4:08 pm
by HondaLee
Yes I did rewire solar array so now wired in strings of 3.