FLEXmax 80 display

Discussion about the FM100, FM80, and FM60 Charge Controllers

Moderators: OutBack, OutBack Moderator Team

Post Reply
HondaLee
Forum Member
Posts: 16
Joined: Thu Dec 13, 2018 10:16 am
My RE system: FLEXmax 500
Vfx3648
FLEXmax 80
Flex ware Gvx3648

FLEXmax 80 display

Post by HondaLee » Thu Dec 13, 2018 10:29 am

After moving to my current location I installed my system and when I turned on dc breakers FLEXmax 80 display has back light and a full screen of black boxes and no letters. The rest of system seems ok so far , can you help

User avatar
Jorge Guzman
Strategic Platforms
Posts: 248
Joined: Thu May 29, 2014 9:44 am
My RE system: VFXR3524A, FM80, MATE3. 3x 260W REC. 4x Trojan L16 FLA 370Ah.
Location: Arlington, WA

Re: FLEXmax 80 display

Post by Jorge Guzman » Thu Dec 13, 2018 12:09 pm

Try doing a "hard reset" on the FM80 controller.

Turn off PV input breaker
Turn off Batt output breaker
While unit is completely off, press and hold buttons #1 and #3 (from left to right)
While still holding the buttons, turn on the battery breaker.

This should reset the unit including settings.
Jorge Guzman
Sr. Strategic Platforms Analyst


Watch easy to follow video tutorials:
https://www.youtube.com/c/wattschool

HondaLee
Forum Member
Posts: 16
Joined: Thu Dec 13, 2018 10:16 am
My RE system: FLEXmax 500
Vfx3648
FLEXmax 80
Flex ware Gvx3648

Re: FLEXmax 80 display

Post by HondaLee » Thu Dec 13, 2018 5:37 pm

I will try that and get back to you.
I have another question: I have a second FLEXmax 80 that I used to change out the one that is giving problems. With replacement charge controller installed and system up and running I am getting 227vac. I plugged in my cripplecreek car charger and it immediately shows power fault. This is the only load I have running through inverters at this time because my first goal is to use solar to charge my Chevy volt. Thanks

User avatar
Kurt Lundquist
Alpha Energy Engineering
Posts: 1447
Joined: Tue May 31, 2011 7:23 am
My RE system: VFX3524, Mate3, 200Ah 24V AGM Battery Bank
Location: Arlington, WA

Re: FLEXmax 80 display

Post by Kurt Lundquist » Fri Dec 14, 2018 8:15 am

What shows the power fault (Inverter or the car charger)?

Which Clipper Creek Charger are you using?

Have you tried running a different AC load off the inverter output?

-Kurt
Kurt Lundquist
Renewable Energy Project Engineer
http://alphaenergy.us/

HondaLee
Forum Member
Posts: 16
Joined: Thu Dec 13, 2018 10:16 am
My RE system: FLEXmax 500
Vfx3648
FLEXmax 80
Flex ware Gvx3648

Re: FLEXmax 80 display

Post by HondaLee » Sat Dec 15, 2018 8:54 am

Clipper creek model LCS-20P
Configuration LCP-20-C11-P1-L25-55
No I havenÔÇÖt tried any other loads yet as I am just getting the system installed but I did check voltage and was getting a little better than 220 vac

HondaLee
Forum Member
Posts: 16
Joined: Thu Dec 13, 2018 10:16 am
My RE system: FLEXmax 500
Vfx3648
FLEXmax 80
Flex ware Gvx3648

Re: FLEXmax 80 display

Post by HondaLee » Sat Dec 15, 2018 10:53 am

Did hard reset on charge controller and it made no difference. Every single caricature has Black box in place of letter over hole screen.
What next?

User avatar
Kurt Lundquist
Alpha Energy Engineering
Posts: 1447
Joined: Tue May 31, 2011 7:23 am
My RE system: VFX3524, Mate3, 200Ah 24V AGM Battery Bank
Location: Arlington, WA

Re: FLEXmax 80 display

Post by Kurt Lundquist » Mon Dec 17, 2018 1:01 pm

HondaLee wrote:I plugged in my cripplecreek car charger and it immediately shows power fault.
Kurt Lundquist wrote:What shows the power fault (Inverter or the car charger)?
For the FM80 with the display issues what is your DC negative to ground voltage when the PV array is connected?

Disconnect the PV array then try turning the controller on again. If you still have black boxes connect the Mate3 to the FM80 to see if it can communicate with the FM. If the Mate3 communicates with the FM you can try connecting the PV array again then look at the Mate3 to see if it is doing anything when it is sunny out.

In another thread, you noted 4 x 60 cell PV modules in series (~37V x 4). This is too much voltage for the controller anytime the PV array is below 80F. I recommend only using 3 of these modules in series. Inside the FM80 wiring compartment you can see two red discs near the Mate/Hub port on the left side. If either of these looks compromised it would be due to high voltage from the array.

-Kurt
Kurt Lundquist
Renewable Energy Project Engineer
http://alphaenergy.us/

HondaLee
Forum Member
Posts: 16
Joined: Thu Dec 13, 2018 10:16 am
My RE system: FLEXmax 500
Vfx3648
FLEXmax 80
Flex ware Gvx3648

Re: FLEXmax 80 display

Post by HondaLee » Tue Dec 18, 2018 4:08 pm

Yes I did rewire solar array so now wired in strings of 3.

Post Reply